Upgrading webserver capacity
Incident Report for Plecto
Resolved
We have completed the upgrade and should now experience faster average page load times.
Posted Feb 12, 2021 - 12:20 CET
Monitoring
We are performing planned maintenance on our hosting insfrastructure which has caused some disruption of service. We are very sorry about the inconveniance this might have caused you and we are focusing on minimizing the disruption of service moving forward.
Posted Feb 12, 2021 - 11:13 CET
This incident affected: Website.