Delays across the platform

Incident Report for Plecto

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 14:19 CET

Identified

We're observing connectivity issues across entire platform that are affecting response times and cause delays in data processing.
Posted Nov 26, 2025 - 13:45 CET
This incident affected: Web application, Widget updates, Notifications delivery, and Registrations processing.