[Resolved] Delays on Dynamic Integrations

Incident Report for Plecto

Resolved

Our recent cloud migration has been completed successfully. Since the migration, we experienced issues with Dynamic Integrations timing out during import operations. This has now been resolved, and dynamic integrations are working as expected.

Thank you for your patience.
Plecto Team
Posted Jul 01, 2025 - 14:38 CEST
This incident affected: Integration data import.