Delays in data processing

Incident Report for Plecto

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 19:03 CET

Update

We are continuing to work on a fix for this issue.
Posted Nov 26, 2025 - 18:38 CET

Identified

We're expriencing connectivity issues caused by our hosting provider which cause delays in data processing.
Posted Nov 26, 2025 - 18:31 CET
This incident affected: Widget updates, Notifications delivery, and Registrations processing.