Issues with importing data and rendering widgets

Incident Report for Plecto

Resolved

The incident has been resolved and are actively processing data again.
Data can still be a bit delayed, but should catch up within the next hour.
We sincerely apologize for the inconvenience and appreciate your patience
Posted Jun 30, 2025 - 22:16 CEST

Identified

We have identified the issue and are currently working on a fix.
Posted Jun 30, 2025 - 19:16 CEST

Investigating

We are currently investigating this issue.
Posted Jun 30, 2025 - 16:50 CEST
This incident affected: Widget updates and Integration data import.