Increased response times
Incident Report for Plecto
Resolved
The issue has been resolved. We are sorry for any inconvenience
Posted Jan 03, 2024 - 10:04 CET
Monitoring
The fix has been implemented and repsonse times are back to normal. We continue to monitor the situation
Posted Jan 03, 2024 - 09:49 CET
Identified
We're currently seeing increased response times on the Plecto application. We're aware of the issue and a fix is being implemented
Posted Jan 03, 2024 - 09:27 CET
This incident affected: Website.