Delayed manual imports
Incident Report for Plecto
Resolved
If you have any uncompleted import jobs, please stop them and restart them, and they should be picked up immediately
Posted Mar 01, 2023 - 21:54 CET
Identified
We are currently facing an issue where manual data imports are delayed. We are working actively to fix it.

Automatic imports are not affected
Posted Mar 01, 2023 - 14:40 CET
This incident affected: Integration data import.