Some notifications delayed
Incident Report for Plecto
Resolved
This incident has been resolved.
Posted Oct 18, 2022 - 13:04 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2022 - 12:42 CEST
Investigating
We are currently investigating this issue
Posted Oct 18, 2022 - 11:37 CEST
This incident affected: Notifications.