E-mail sending suspended
Incident Report for Plecto
Resolved
Email sending has been restored. Please contact support if your email were still not delivered.
Posted Jan 24, 2020 - 11:10 CET
Investigating
We have identified an issue with our e-mail sending provider. All notification, password reset and other emails are delayed until we resolve the problem. We apologize for the inconvenience and are working with our provided to find a solution as soon as possible.
Posted Jan 24, 2020 - 09:02 CET