E-mail sending suspended
Incident Report for Plecto
Resolved
Email delivery now works again. Sorry for the disruption.
Posted about 1 year ago. May 25, 2018 - 14:51 CEST
Identified
We have identified an issue with our e-mail sending provider. All notification, password reset and other emails are delayed until we resolve the problem. We apologize for the inconvenience and are working with our provided to find a solution as soon as possible.
Posted about 1 year ago. May 24, 2018 - 21:51 CEST