Automatic import delay
Incident Report for Plecto
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 14:56 CEST
Investigating
We have identified a problem with the automatic data import. We are working on a fix as fast as possible.
Posted Apr 27, 2020 - 13:08 CEST