Investigating problems with dashboard updates
Incident Report for Plecto
Resolved
We have resolved the problem and will keep working on fixing it permanently.
Posted 5 months ago. Aug 11, 2017 - 14:15 CEST
Investigating
We are investigating an issue with automatic dashboard updates not working as intended for all users.
Posted 5 months ago. Aug 11, 2017 - 13:47 CEST